]> Pileus Git - ~andy/sunrise/blob - dev-python/lazr-restfulclient/lazr-restfulclient-0.12.0.ebuild
sunrise/ net-nntp/nzbperl/Manifest: Update copyright line to satisfy repoman
[~andy/sunrise] / dev-python / lazr-restfulclient / lazr-restfulclient-0.12.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6 PYTHON_DEPEND="2:2.6"
7 SUPPORT_PYTHON_ABIS="1"
8
9 inherit distutils
10
11 MY_P=${PN/-/.}-${PV}
12 DESCRIPTION="Client for the lazr.restful web services"
13 HOMEPAGE="https://launchpad.net/lazr.restfulclient"
14 SRC_URI="http://launchpad.net/${PN/-/.}/trunk/${PV}/+download/${MY_P}.tar.gz"
15
16 LICENSE="LGPL-3"
17 SLOT="0"
18 KEYWORDS="~amd64"
19 IUSE=""
20
21 RDEPEND="dev-python/lazr-uri
22         dev-python/httplib2
23         dev-python/oauth
24         dev-python/simplejson
25         dev-python/wadllib
26         net-zope/zope-interface"
27
28 S=${WORKDIR}/${MY_P}
29 RESTRICT_PYTHON_ABIS="2.[45] 3.*"
30
31 PYTHON_MODNAME="lazr/restfulclient"