]> Pileus Git - ~andy/sunrise/blob - dev-python/jpype/jpype-0.5.4.1.ebuild
app-accessibility/onboard: Update Manifest
[~andy/sunrise] / dev-python / jpype / jpype-0.5.4.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6 SUPPORT_PYTHON_ABIS=1
7 PYTHON_DEPEND=2
8 RESTRICT_PYTHON_ABIS='3.*'
9
10 inherit distutils
11
12 MY_PN=JPype
13 MY_P=${MY_PN}-${PV}
14
15 DESCRIPTION="Allow python programs full access to java class libraries"
16 HOMEPAGE="http://jpype.sourceforge.net"
17 SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
18
19 LICENSE="Apache-2.0"
20 KEYWORDS="~amd64 ~x86"
21 SLOT="0"
22 IUSE="examples"
23
24 RDEPEND=""
25 DEPEND="app-arch/unzip"
26
27 S="${WORKDIR}"/${MY_P}
28
29 src_install() {
30         distutils_src_install
31
32         if use examples; then
33                 insinto /usr/share/doc/${PF}/examples
34                 doins -r {examples,test} || die
35         fi
36 }