]> Pileus Git - ~andy/sunrise/blob - dev-python/formbuild/formbuild-2.2.0.ebuild
sci-visualization/tulip: Fix qt deps
[~andy/sunrise] / dev-python / formbuild / formbuild-2.2.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6 SUPPORT_PYTHON_ABIS="1"
7
8 inherit distutils
9
10 MY_PN="FormBuild"
11 MY_P="${MY_PN}-${PV}"
12
13 DESCRIPTION="Build forms quickly and easily using groups of simple helper functions"
14 HOMEPAGE="http://jimmyg.org/work/code/formbuild/index.html"
15 SRC_URI="http://cheeseshop.python.org/packages/source/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
16
17 LICENSE="GPL-3"
18 SLOT="0"
19 KEYWORDS="~amd64"
20 IUSE="test"
21
22 DEPEND="dev-python/setuptools
23         test? ( dev-python/nose )"
24 RDEPEND=""
25 RESTRICT_PYTHON_ABIS="3.*"
26
27 S="${WORKDIR}/${MY_P}"
28
29 src_test() {
30         testing() {
31                 PYTHONPATH="build-${PYTHON_ABI}/lib" LC_ALL="C" nosetests-${PYTHON_ABI}
32         }
33         python_execute_function testing
34 }