]> Pileus Git - ~andy/sunrise/blob - dev-python/factory_boy/factory_boy-1.1.3.ebuild
games-board/qbriscola: Fix qt deps, EAPI bump, add ~amd64 keyword
[~andy/sunrise] / dev-python / factory_boy / factory_boy-1.1.3.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 PYTHON_DEPEND="2:2.5"
8 SUPPORT_PYTHON_ABIS="1"
9 RESTRICT_PYTHON_ABIS="3.*"
10
11 DISTUTILS_SRC_TEST="setup.py"
12
13 inherit distutils
14
15 DESCRIPTION="A versatile test fixtures replacement"
16 HOMEPAGE="http://pypi.python.org/pypi/factory_boy/"
17 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
18
19 LICENSE="MIT"
20 SLOT="0"
21 KEYWORDS="~amd64 ~x86"
22 IUSE="doc test"
23
24 RDEPEND=""
25 DEPEND="doc? ( dev-python/sphinx )"
26
27 src_compile() {
28         distutils_src_compile
29
30         if use doc; then
31                 einfo "Generation of documentation"
32                 emake -C docs html
33         fi
34 }
35
36 src_install() {
37         distutils_src_install
38
39         if use doc; then
40                 dohtml -r -A txt docs/_build/html/*
41         fi
42 }