]> Pileus Git - ~andy/sunrise/blob - dev-python/eggtranslations/eggtranslations-1.2.ebuild
dev-python/eggtranslations: Switch to pypi mirror list
[~andy/sunrise] / dev-python / eggtranslations / eggtranslations-1.2.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit distutils
6
7 MY_PN="EggTranslations"
8 MY_P="${MY_PN}-${PV}"
9
10 DESCRIPTION="Provides an API for accessing localizations and resources packaged in python eggs"
11 HOMEPAGE="http://chandlerproject.org/Projects/EggTranslations"
12 SRC_URI="mirror://pypi/E/${MY_PN}/${MY_P}.tar.gz"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="~x86"
17 IUSE="doc"
18
19 DEPEND="doc? ( dev-python/epydoc )"
20 RDEPEND="dev-python/configobj"
21
22 S="${WORKDIR}/${MY_P}"
23
24 DOCS="README.txt"
25
26 src_compile() {
27         if use doc; then
28                 epydoc --html --verbose --url="${HOMEPAGE}" --name="${MY_P}" egg_translations.py \
29                         || die "Making the docs failed!"
30         fi
31         distutils_src_compile
32 }
33
34 src_test() {
35         PYTHONPATH="build/lib/" "${python}" setup.py test || die "Completing the tests failed!"
36 }
37
38 src_install() {
39         if use doc; then
40                 dohtml html/* || die "Installing the docs failed!"
41         fi
42         distutils_src_install
43 }