]> Pileus Git - ~andy/sunrise/blob - dev-python/eggtranslations/eggtranslations-1.2.1.ebuild
games-strategy/freesynd: in main tree
[~andy/sunrise] / dev-python / eggtranslations / eggtranslations-1.2.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6 SUPPORT_PYTHON_ABIS=1
7 PYTHON_DEPEND='2'
8 RESTRICT_PYTHON_ABIS='3.*'
9
10 inherit distutils
11
12 MY_PN="EggTranslations"
13 MY_P="${MY_PN}-${PV}"
14
15 DESCRIPTION="Provides an API for accessing localizations and resources packaged in python eggs"
16 HOMEPAGE="http://chandlerproject.org/Projects/EggTranslations"
17 SRC_URI="mirror://pypi/E/${MY_PN}/${MY_P}.tar.gz"
18
19 LICENSE="Apache-2.0"
20 SLOT="0"
21 KEYWORDS="~amd64 ~x86"
22 IUSE="doc"
23
24 DEPEND="doc? ( dev-python/epydoc )"
25 RDEPEND="dev-python/configobj"
26
27 S="${WORKDIR}/${MY_P}"
28
29 DOCS="README.txt"
30
31 DISTUTILS_SRC_TEST=setup.py
32
33 src_compile() {
34         if use doc; then
35                 epydoc --html --verbose --url="${HOMEPAGE}" --name="${MY_P}" egg_translations.py \
36                         || die "Making the docs failed!"
37         fi
38         distutils_src_compile
39 }
40
41 src_install() {
42         if use doc; then
43                 dohtml html/* || die "Installing the docs failed!"
44         fi
45         distutils_src_install
46 }