]> Pileus Git - ~andy/sunrise/blob - dev-python/cx-oracle/cx-oracle-5.0.2.ebuild
games-board/qbriscola: Fix qt deps, EAPI bump, add ~amd64 keyword
[~andy/sunrise] / dev-python / cx-oracle / cx-oracle-5.0.2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 inherit distutils
8
9 MY_PN=cx_Oracle
10 MY_P=${MY_PN}-${PV}
11 DESCRIPTION="Python interface to Oracle"
12 HOMEPAGE="http://www.cxtools.net/default.aspx?nav=cxorlb"
13 SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
14
15 LICENSE="Computronix"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="doc examples"
19
20 DEPEND=">=dev-db/oracle-instantclient-basic-10.2.0.3"
21 RDEPEND="${DEPEND}"
22
23 S=${WORKDIR}/${MY_P}
24
25 DOCS="README.txt HISTORY.txt"
26
27 src_install() {
28         distutils_src_install
29
30         if use doc; then
31                 dohtml -r html/* || die
32         fi
33
34         if use examples; then
35                 docinto examples
36                 dodoc samples/* || die
37         fi
38 }