]> Pileus Git - ~andy/sunrise/blob - dev-python/configglue/configglue-1.0.ebuild
games-board/qbriscola: Fix qt deps, EAPI bump, add ~amd64 keyword
[~andy/sunrise] / dev-python / configglue / configglue-1.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6 PYTHON_DEPEND="2:2.5"
7 SUPPORT_PYTHON_ABIS="1"
8
9 inherit distutils
10
11 DESCRIPTION="Glue to stick OptionParser and ConfigParser together"
12 HOMEPAGE="https://launchpad.net/configglue"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0"
17 KEYWORDS="~amd64"
18 IUSE="test"
19
20 DEPEND="test? ( dev-python/mock )"
21 RDEPEND="dev-python/pyxdg"
22
23 RESTRICT_PYTHON_ABIS="2.4 3.*"
24
25 src_test() {
26         testing() {
27                 PYTHONPATH="build-${PYTHON_ABI}" "$(PYTHON)" setup.py test
28         }
29         python_execute_function testing
30 }