]> Pileus Git - ~andy/sunrise/blob - dev-python/concurrence/concurrence-0.3.1.ebuild
3a9a5365f8dc9928702d6a9ad41dcccaaacf3368
[~andy/sunrise] / dev-python / concurrence / concurrence-0.3.1.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit distutils
6
7 DESCRIPTION="Concurrence is a framework for creating massively concurrent network applications in Python"
8 HOMEPAGE="http://opensource.hyves.org/concurrence"
9 SRC_URI="http://concurrence.googlecode.com/files/${P}.tar.gz"
10
11 LICENSE="BSD-2"
12 KEYWORDS="~amd64 ~x86"
13 SLOT="0"
14 IUSE="doc examples"
15
16 DEPEND=">=dev-lang/python-2.5
17         dev-python/setuptools"
18 RDEPEND="${DEPEND}"
19
20
21 src_install() {
22         distutils_src_install
23
24         if use doc; then
25                 dodoc doc/*
26         fi
27
28         if use examples; then
29                 docinto examples
30                 dodoc examples/* || die "dodoc failed"
31         fi
32 }
33
34 src_test() {
35         PYTHONPATH="build/lib" "${python}" setup.py test || die "Tests failed"
36 }
37