]> Pileus Git - ~andy/sunrise/blob - dev-python/bottle/bottle-0.10.2.ebuild
net-misc/geomyidae: Version bump
[~andy/sunrise] / dev-python / bottle / bottle-0.10.2.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 PYTHON_DEPEND="2:2.5 3"
8 SUPPORT_PYTHON_ABIS="1"
9 RESTRICT_PYTHON_ABIS="2.4"
10 PYTHON_TESTS_RESTRICTED_ABIS="3.*"
11
12 inherit distutils
13
14 DESCRIPTION="A fast and simple micro-framework for small web-applications"
15 HOMEPAGE="http://bottle.paws.de/"
16 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
17
18 LICENSE="MIT"
19 SLOT="0"
20 KEYWORDS="~amd64 ~x86"
21 IUSE=""
22
23 PYTHON_MODNAME=${PN}.py
24
25 src_test() {
26         testing() {
27                 PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test/testall.py || die
28         }
29         python_execute_function testing
30 }