]> Pileus Git - ~andy/sunrise/blob - dev-python/Whoosh/Whoosh-2.3.2.ebuild
app-editors/yzis: Fix qt deps, EAPI bump
[~andy/sunrise] / dev-python / Whoosh / Whoosh-2.3.2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 PYTHON_DEPEND="2:2.5 3:3.1"
8 SUPPORT_PYTHON_ABIS="1"
9 RESTRICT_PYTHON_ABIS="2.4"
10 DISTUTILS_SRC_TEST="setup.py"
11 PYTHON_TESTS_RESTRICTED_ABIS="3.*"
12 PYTHON_MODNAME="whoosh"
13
14 inherit distutils
15
16 DESCRIPTION="Fast, pure-Python full text indexing, search and spell checking library"
17 HOMEPAGE="http://bitbucket.org/mchaput/whoosh/wiki/Home/ http://pypi.python.org/pypi/Whoosh/"
18 SRC_URI="mirror://pypi/W/${PN}/${P}.tar.gz"
19
20 LICENSE="Apache-2.0"
21 SLOT="0"
22 KEYWORDS="~amd64 ~x86"
23 IUSE="doc"
24
25 src_install() {
26         distutils_src_install
27
28         if use doc; then
29                 insinto "/usr/share/doc/${PF}/"
30                 doins -r docs/build/html/_sources/* || die
31         fi
32 }