]> Pileus Git - ~andy/sunrise/blob - dev-python/Chameleon/Chameleon-2.0_rc8.ebuild
dev-db/cppdb: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / dev-python / Chameleon / Chameleon-2.0_rc8.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 SUPPORT_PYTHON_ABIS=1
8 PYTHON_DEPEND="2:2.7 3"
9 DISTUTILS_SRC_TEST="setup.py"
10
11 inherit distutils
12
13 MY_P=${P/_/-}
14
15 DESCRIPTION="Fast XML template compiler for Python"
16 HOMEPAGE="http://chameleon.repoze.org"
17 SRC_URI="mirror://pypi/${P:0:1}/${PN}/${MY_P}.tar.gz"
18
19 LICENSE="repoze"
20 SLOT="0"
21 KEYWORDS="~amd64 ~x86"
22 IUSE="doc test"
23
24 DEPEND="doc? ( dev-python/sphinx )"
25 RDEPEND=""
26
27 S="${WORKDIR}/${MY_P}"
28
29 RESTRICT_PYTHON_ABIS="2.[456]"
30
31 src_compile() {
32         distutils_src_compile
33
34         if use doc ; then
35                 emake html || die "make html failed"
36         fi
37 }
38
39 src_install() {
40         distutils_src_install
41
42         if use doc ; then
43                 dohtml -r _build/html/* || die "dohtml failed"
44         fi
45 }