]> Pileus Git - ~andy/sunrise/blob - dev-perl/Authen-SASL-Cyrus-server/Authen-SASL-Cyrus-server-0.13.ebuild
729be8ec4a358ae9b9a290b06b12e53ef88dbdf2
[~andy/sunrise] / dev-perl / Authen-SASL-Cyrus-server / Authen-SASL-Cyrus-server-0.13.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit perl-module
6
7 MY_P="${P//-server}-server"
8 AUTHOR="PBOETTCH"
9 DESCRIPTION="A Perl SASL interface using the Cyrus SASL library (server version)"
10 HOMEPAGE="http://search.cpan.org/~pboettch/Authen-SASL-Cyrus/"
11 SRC_URI="mirror://cpan/authors/id/${AUTHOR:0:1}/${AUTHOR:0:2}/${AUTHOR}/${MY_P}.tar.gz"
12
13 LICENSE="|| ( Artistic GPL-2 )"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND=">=dev-perl/Authen-SASL-2.06
19         >=dev-libs/cyrus-sasl-2"
20 RDEPEND="${DEPEND}
21         !dev-perl/Authen-SASL-Cyrus"
22
23 S="${WORKDIR}/${MY_P}"
24
25 SRC_TEST="do"
26 export OPTIMIZE="$CFLAGS"
27 myconf="INC=-I/usr/include/sasl LIBS=-lsasl2 DEFINE=-DSASL2"