]> Pileus Git - ~andy/sunrise/blob - dev-perl/Apt-Pkg/Apt-Pkg-0.1.26.ebuild
app-misc/autokey-gtk: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / dev-perl / Apt-Pkg / Apt-Pkg-0.1.26.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="5"
6
7 inherit perl-module
8
9 MY_PN="libapt-pkg-perl"
10
11 DESCRIPTION="Perl interface to libapt-pkg"
12 HOMEPAGE="http://packages.qa.debian.org/libapt-pkg-perl"
13 SRC_URI="mirror://debian/pool/main/liba/${MY_PN}/${MY_PN}_${PV}.tar.gz"
14
15 LICENSE="GPL-2+"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="examples"
19
20 RDEPEND="sys-apps/apt[apt-pkg]
21         virtual/libstdc++:3.3
22         virtual/perl-Scalar-List-Utils"
23 DEPEND="virtual/perl-ExtUtils-MakeMaker
24         ${RDEPEND}"
25
26 S="${WORKDIR}/${MY_PN}-${PV}"
27
28 src_compile() {
29         # MakeMaker does not respect CC/CXX
30         mymake=( CC=$(tc-getCXX) )
31         perl-module_src_compile
32 }
33
34 src_install() {
35         perl-module_src_install
36         # Install coding examples
37         dodoc debian/changelog
38         if use examples; then
39                 dodoc -r examples
40         fi
41 }