]> Pileus Git - ~andy/sunrise/blob - dev-libs/tntdb/tntdb-1.2.ebuild
net-misc/fatrat: Properly fix qt deps
[~andy/sunrise] / dev-libs / tntdb / tntdb-1.2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="4"
6
7 DESCRIPTION="A c++-class-library for easy and light database-access. Currently for postgresql, sqlite3 and mysql"
8 HOMEPAGE="http://www.tntnet.org/tntdb.html"
9 SRC_URI="http://www.tntnet.org/download/${P}.tar.gz"
10 LICENSE="LGPL-2.1"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="doc mysql postgres sqlite"
14 REQUIRED_USE="|| ( mysql postgres sqlite )"
15
16 RDEPEND="mysql? ( virtual/mysql )
17         postgres? ( dev-db/postgresql-base )
18         sqlite? ( dev-db/sqlite:3 )
19         >=dev-libs/cxxtools-2.1"
20 DEPEND="${RDEPEND}
21         doc? ( app-doc/doxygen )"
22
23 src_configure() {
24         econf \
25                 $(use_with mysql) \
26                 $(use_with postgres postgresql) \
27                 $(use_with sqlite) \
28                 $(use_with doc doxygen) \
29                 --docdir=/usr/share/doc/${PF} \
30                 --htmldir=/usr/share/doc/${PF}/html
31 }
32
33 src_install() {
34         default
35         dodoc doc/*.pdf
36
37         insinto /usr/share/doc/${PF}/examples
38         doins demo/*.{cpp,h}
39 }