]> Pileus Git - ~andy/sunrise/blob - dev-libs/tntdb/tntdb-1.0.1.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / dev-libs / tntdb / tntdb-1.0.1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 DESCRIPTION="A c++-class-library for easy and light database-access. Currently for postgresql, sqlite3 and mysql"
8 HOMEPAGE="http://www.tntnet.org/tntdb.hms"
9 SRC_URI="http://www.tntnet.org/download/${P}.tar.gz"
10 LICENSE="LGPL-2"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="doc mysql postgres sqlite"
14
15 RDEPEND="mysql? ( virtual/mysql )
16         postgres? ( virtual/postgresql-base )
17         sqlite? ( dev-db/sqlite:3 )
18         >=dev-libs/cxxtools-1.4.8"
19 DEPEND="${RDEPEND}
20         doc? ( app-doc/doxygen )"
21
22 src_configure() {
23         econf \
24                 $(use_with mysql) \
25                 $(use_with postgres postgresql) \
26                 $(use_with sqlite) \
27                 $(use_with doc doxygen) \
28                 --docdir=/usr/share/doc/${PF} \
29                 --htmldir=/usr/share/doc/${PF}/html
30 }
31
32 src_install() {
33         emake DESTDIR="${D}" install || die "emake install failed"
34         dodoc AUTHORS ChangeLog README NEWS doc/*.pdf
35
36         insinto /usr/share/doc/${PF}/examples
37         doins demo/*.{cpp,h}
38 }