]> Pileus Git - ~andy/sunrise/blob - dev-libs/openthreads/openthreads-1.5.0.ebuild
sunrise/app-portage/overlay-utils/overlay-utils-0.2.ebuild: Update copyright headers...
[~andy/sunrise] / dev-libs / openthreads / openthreads-1.5.0.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils fixheadtails toolchain-funcs multilib
6
7 MY_PN="OpenThreads"
8 OSG_V=1.2
9 DESCRIPTION="a minimal & complete Object-Oriented thread interface for C++"
10 HOMEPAGE="http://www.openscenegraph.org/"
11 SRC_URI="http://www.openscenegraph.org/downloads/snapshots/OSG_OP_OT-${OSG_V}.zip"
12
13 LICENSE="LGPL-2.1"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE="doc examples"
17
18 DEPEND="app-arch/unzip
19         doc? ( app-doc/doxygen )"
20 RDEPEND=""
21
22 S=${WORKDIR}/OSG_OP_OT-${OSG_V}/${MY_PN}
23
24 src_unpack() {
25         unpack ${A}
26         cd "${S}"
27         epatch "${FILESDIR}"/${P}-build.patch
28
29         ht_fix_all
30 }
31
32 src_compile() {
33         emake CXX=$(tc-getCXX) || die "emake failed"
34
35         if use doc; then
36                 cd docs
37                 doxygen doxyfile
38         fi
39 }
40
41 src_install() {
42         emake INST_LOCATION="${D}"/usr install || die "emake install failed"
43
44         dosym /usr/$(get_libdir)/lib${MY_PN}.so{.${PV},}
45         dosym /usr/$(get_libdir)/lib${MY_PN}.so.{${PV},${PV%%.*}}
46
47         insinto /usr/$(get_libdir)/pkgconfig
48         doins Make/openthreads.pc
49
50         dodoc AUTHORS.txt ChangeLog README.txt TODO.txt
51
52         use doc && dohtml -r docs/html/*
53
54         if use examples; then
55                 insinto /usr/share/doc/${PF}/examples
56                 doins -r examples_src/*
57         fi
58 }