]> Pileus Git - ~andy/sunrise/blob - dev-libs/libwiimote/libwiimote-9999.ebuild
Use pkgconfig virtual.
[~andy/sunrise] / dev-libs / libwiimote / libwiimote-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils subversion autotools
6
7 ESVN_REPO_URI="https://libwiimote.svn.sourceforge.net/svnroot/${PN}/branches/ant"
8 ESVN_PROJECT="libwiimote"
9
10 DESCRIPTION="Library to connect to the Nintendo Wii remote (svn snapshot)"
11 HOMEPAGE="http://libwiimote.sourceforge.net"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS=""
16 IUSE="examples"
17
18 RDEPEND="net-wireless/bluez"
19 DEPEND="${RDEPEND}
20                 virtual/pkgconfig"
21
22 src_unpack() {
23         subversion_src_unpack
24         epatch "${FILESDIR}/${P}-ldflags.patch"
25         eautoreconf
26 }
27
28 src_install() {
29         emake DESTDIR="${D}" install || die "emake install failed"
30         dodoc AUTHORS NEWS README TODO || die "dodoc failed"
31
32         if use examples; then
33                 docinto examples
34                 dodoc test/test?.c || die "dodoc examples failed"
35         fi
36 }