]> Pileus Git - ~andy/sunrise/blob - dev-libs/libwiimote/libwiimote-0.4.ebuild
x11-themes/gtk-themes-h2o-gtk2: Add ~amd64 keyword
[~andy/sunrise] / dev-libs / libwiimote / libwiimote-0.4.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils autotools
8
9 DESCRIPTION="Library to connect to the Nintendo Wii remote"
10 HOMEPAGE="http://libwiimote.sourceforge.net"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="examples force tilt"
17
18 RDEPEND="net-wireless/bluez"
19 DEPEND=${RDEPEND}
20
21 src_prepare() {
22         epatch "${FILESDIR}"/${PN}-{amd64,as-needed,include,hci}.patch
23         use "tilt" || sed -i -e "s:-D_ENABLE_TILT::" config.mk.in
24         use "force" || sed -i -e "s:-D_ENABLE_FORCE::" config.mk.in
25         eautoreconf
26 }
27
28 src_install() {
29         emake DESTDIR="${D}" install || die "emake install failed"
30         dodoc AUTHORS NEWS README TODO || die "dodoc failed"
31
32         if use examples; then
33                 docinto examples
34                 dodoc test/test?.c || die "dodoc examples failed"
35         fi
36 }