]> Pileus Git - ~andy/sunrise/blob - dev-libs/libuv/libuv-0.7.6_p20120404.ebuild
games-board/qbriscola: Fix qt deps, EAPI bump, add ~amd64 keyword
[~andy/sunrise] / dev-libs / libuv / libuv-0.7.6_p20120404.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit flag-o-matic toolchain-funcs
8
9 DESCRIPTION="A new platform layer for Node"
10 HOMEPAGE="https://github.com/joyent/libuv"
11 SRC_URI="mirror://github/hasufell/tinkerbox/${P}.tar.gz"
12 # commit bf9a2b346306583d1eff9b14b3a2b85f9768cb83
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 src_compile() {
20         tc-export CC AR
21         append-flags -fno-strict-aliasing
22         emake
23 }
24
25 src_install() {
26         insinto /usr/include
27         doins -r include/*
28         newlib.a uv.a ${PN}.a
29
30         newdoc README.md README
31 }