]> Pileus Git - ~andy/sunrise/blob - dev-libs/libref_array/libref_array-0.1.1.ebuild
2c7cc0f33d8027c3932b2188fba088a7cfb144b1
[~andy/sunrise] / dev-libs / libref_array / libref_array-0.1.1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 DESCRIPTION="Dynamic array with reference count library"
8 HOMEPAGE="http://fedorahosted.org/sssd/wiki/"
9 SRC_URI="http://fedorahosted.org/released/ding-libs/${P}.tar.gz"
10
11 LICENSE="|| ( GPL-3 LGPL-3 )"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="doc static-libs trace"
15
16 DEPEND="doc? ( app-doc/doxygen )"
17 RDEPEND=""
18
19 src_configure() {
20         econf \
21                 $(use_enable trace trace 7) \
22                 $(use_enable static-libs static)
23 }
24
25 src_compile() {
26         default
27         if use doc; then
28                 emake docs || die
29         fi
30 }
31
32 src_install() {
33         emake DESTDIR="${D}" install || die
34         if use doc; then
35                 dohtml -r doc/html/ || die
36         fi
37 }