]> Pileus Git - ~andy/sunrise/blob - dev-libs/libmail/libmail-0.3.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / dev-libs / libmail / libmail-0.3.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="a mail handling library"
6 HOMEPAGE="http://libmail.sourceforge.net"
7 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
8
9 LICENSE="GPL-3"
10 SLOT="0"
11 KEYWORDS="~x86"
12 IUSE="apop debug gnutls profile sasl"
13
14 DEPEND="gnutls? ( >=net-libs/gnutls-2 )
15         sasl? ( >=dev-libs/cyrus-sasl-2 )"
16 RDEPEND="${DEPEND}"
17
18 src_compile() {
19         econf \
20                 $(use_enable apop) \
21                 $(use_enable debug ) \
22                 $(use_enable gnutls tls) \
23                 $(use_enable profile ) \
24                 $(use_enable sasl)
25         emake || die "emake failed"
26 }
27
28 src_install() {
29         emake DESTDIR="${D}" install || die "Install failed"
30         dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
31 }