]> Pileus Git - ~andy/sunrise/blob - dev-libs/libdbf/libdbf-0.0.1.ebuild
sunrise/ net-nntp/nzbperl/Manifest: Update copyright line to satisfy repoman
[~andy/sunrise] / dev-libs / libdbf / libdbf-0.0.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 DESCRIPTION="Library to read the content of dBASE III, IV, and 5.0 files"
8 HOMEPAGE="http://developer.berlios.de/projects/dbf/"
9 SRC_URI="mirror://berlios/dbf/${P}.src.zip"
10
11 LICENSE="LGPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="doc"
15
16 RDEPEND=""
17 DEPEND="${RDEPEND}
18         app-arch/unzip
19         dev-perl/XML-Parser
20         doc? ( app-text/docbook-sgml-utils )
21         dev-util/pkgconfig"
22
23 S=${WORKDIR}/${PN}
24
25 src_prepare() {
26         # Avoid collisions with /usr/include/endian.h
27         # installed by e.g. sys-libs/glibc-2.12.1-r1
28         cd src || die "src dir missing"
29         mv endian.h dbf_endian.h || die "endian.h couldn't be renamed"
30         sed -i 's/endian\.h/dbf_endian.h/g' Makefile.in *.c *.h \
31                 || die "error executing sed"
32 }
33
34 src_configure() {
35         chmod u+x configure
36         if use doc; then
37                 export DOC_TO_MAN=docbook2man
38         fi
39         econf
40 }
41
42 src_install() {
43         chmod u+x install-sh
44         emake DESTDIR="${D}" install || die "make install failed"
45 }