]> Pileus Git - ~andy/sunrise/blob - dev-libs/libcitadel/libcitadel-7.85.ebuild
dev-ruby/rjb: New ebuild for bug #353101
[~andy/sunrise] / dev-libs / libcitadel / libcitadel-7.85.ebuild
1
2 # Copyright 1999-2011 Gentoo Foundation
3 # Distributed under the terms of the GNU General Public License v2
4 # $Header: $
5
6 EAPI=2
7
8 inherit flag-o-matic
9
10 DESCRIPTION="Contains code which is shared across all the components which make up the Citadel system"
11 HOMEPAGE="http://citadel.org/"
12 SRC_URI="http://easyinstall.citadel.org/${P}.tar.gz"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 DEPEND="sys-libs/db
20         >=dev-libs/libical-0.43
21         mail-filter/libsieve
22         dev-libs/expat
23         net-misc/curl"
24
25 RDEPEND="${DEPEND}"
26
27 src_configure() {
28         filter-flags -finline-functions
29         replace-flags -03 -02
30         econf
31 }
32
33 src_install() {
34         emake DESTDIR="${D}" install || die "emake install failed"
35 }