]> Pileus Git - ~andy/sunrise/blob - dev-libs/libaxl/libaxl-0.6.4.ebuild
sci-libs/grits: Version bump for grits-0.8.1
[~andy/sunrise] / dev-libs / libaxl / libaxl-0.6.4.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit autotools eutils
8
9 REVNUM="b4604.g4608"
10 MY_P="${PN/lib}-${PV}.${REVNUM}"
11
12 DESCRIPTION="Another XML library"
13 HOMEPAGE="http://www.aspl.es/axl/"
14 SRC_URI="mirror://sourceforge/vortexlibrary/${MY_P}.tar.gz"
15
16 LICENSE="LGPL-2.1"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="doc tests"
20
21 DEPEND="sys-devel/libtool
22         virtual/pkgconfig
23         doc? ( app-doc/doxygen )"
24
25 S=${WORKDIR}/${MY_P}
26
27 src_prepare() {
28         epatch "${FILESDIR}"/${P}-werror.patch
29
30         eautoreconf
31 }
32
33 src_configure() {
34         econf \
35                 $(use_enable doc axl-doc) \
36                 $(use_enable tests axl-test)
37 }