]> Pileus Git - ~andy/sunrise/blob - dev-libs/libaxl/libaxl-0.6.3.ebuild
e1a2c7eac17bf4a606f39f133d29a94f46c831fa
[~andy/sunrise] / dev-libs / libaxl / libaxl-0.6.3.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 REVNUM="b4475.g4476"
8 MY_P="${PN/lib}-${PV}.${REVNUM}"
9
10 DESCRIPTION="Another XML library"
11 HOMEPAGE="http://www.aspl.es/axl/"
12 SRC_URI="mirror://sourceforge/vortexlibrary/${MY_P}.tar.gz"
13
14 LICENSE="LGPL-2.1"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="doc tests"
18
19 RDEPEND=""
20 DEPEND="sys-devel/libtool
21         dev-util/pkgconfig
22         doc? ( app-doc/doxygen )"
23
24 S="${WORKDIR}/${MY_P}"
25
26 src_configure() {
27         econf \
28                 $(use_enable doc axl-doc) \
29                 $(use_enable tests axl-test)
30 }
31
32 src_install() {
33         emake DESTDIR="${D}" install || die "install failed"
34         dodoc README NEWS AUTHORS ChangeLog || die "dodoc failed"
35 }