]> Pileus Git - ~andy/sunrise/blob - dev-libs/dswifi/dswifi-0.3.12.ebuild
dev-libs/qextserialport: Fix qt deps, EAPI bump
[~andy/sunrise] / dev-libs / dswifi / dswifi-0.3.12.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="Wifi for Nintendo DS Homebrew Development"
6 HOMEPAGE="http://akkit.org/dswifi/"
7 SRC_URI="mirror://sourceforge/devkitpro/${PN}-src-${PV}.tar.bz2"
8
9 LICENSE="GPL-2"
10 SLOT="0"
11 KEYWORDS="~x86"
12 IUSE=""
13
14 DEPEND=">=dev-util/devkitarm-bin-21
15         dev-libs/libnds"
16 RDEPEND="${DEPEND}"
17
18 S=${WORKDIR}
19 RESTRICT="strip"
20
21 src_compile() {
22         export DEVKITPRO=/opt/devkitpro
23         export DEVKITARM=${DEVKITPRO}/devkitARM
24
25         local PATH=${PATH}:${DEVKITARM}/bin
26         emake || die "make failed"
27 }
28
29 src_install() {
30         insinto "${DEVKITPRO}"/libnds
31         into "${DEVKITPRO}"/libnds
32
33         # libs installation
34         dolib.a lib/*.a || die
35
36         # headers installation
37         doins -r include/ || die
38 }