]> Pileus Git - ~andy/sunrise/blob - dev-libs/dswifi/dswifi-0.3.1.ebuild
dev-libs/libnds: Update Ebuild for bug 179226.
[~andy/sunrise] / dev-libs / dswifi / dswifi-0.3.1.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="Wifi for Nintendo DS Homebrew Development"
6 HOMEPAGE="http://akkit.org/dswifi/"
7 SRC_URI="mirror://sourceforge/devkitpro/dswifi-src-${PV}.tar.bz2"
8
9 LICENSE="GPL-2"
10 SLOT="0"
11 KEYWORDS="~x86"
12 IUSE=""
13
14 DEPEND="dev-util/devkitarm-bin
15                 dev-libs/libnds"
16 RDEPEND="${DEPEND}"
17
18 S=${WORKDIR}
19 RESTRICT="strip"
20
21 DEVKITPRO=/opt/devkitpro
22
23 src_compile() {
24         local DEVKITARM=${DEVKITPRO}/devkitARM
25         local PATH=${PATH}:"${DEVKITARM}/bin"
26         emake || die "make failed"
27 }
28
29 src_install() {
30         local INSTDIR=/opt/devkitpro/libnds
31
32         # libs installation
33         insinto "${INSTDIR}"/lib
34         doins lib/*.a
35
36         # headers installation
37         insinto "${INSTDIR}"
38         doins -r include/
39 }