]> Pileus Git - ~andy/sunrise/blob - dev-lang/vala/vala-0.3.1.ebuild
f4d707c2e9ad3258fb08240cb97b5aedb5a0a8d3
[~andy/sunrise] / dev-lang / vala / vala-0.3.1.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="1"
6 GCONF_DEBUG="no"
7
8 inherit gnome2
9
10 DESCRIPTION="Vala - Compiler for the GObject type system"
11 HOMEPAGE="http://live.gnome.org/Vala"
12
13 LICENSE="LGPL-2.1"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="doc gtk +vapigen"
17
18 RDEPEND=">=dev-libs/glib-2.12.0
19         gtk? ( >=x11-libs/gtk+-2.10.0 )"
20 DEPEND="${RDEPEND}
21         >=dev-util/pkgconfig-0.9
22         doc? ( dev-libs/libxslt )"
23
24 DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
25
26 pkg_setup() {
27         G2CONF="${G2CONF} $(use_enable vapigen) $(use_enable gtk gen-project)"
28 }