]> Pileus Git - ~andy/sunrise/blob - dev-lang/tkgofer/tkgofer-2.1-r1.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / dev-lang / tkgofer / tkgofer-2.1-r1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils multilib
6
7 DESCRIPTION="Gofer interpreter including Tcl/Tk interface"
8 HOMEPAGE="http://www.informatik.uni-ulm.de/pm/projekte/TkGofer/"
9 SRC_URI="http://www.informatik.uni-ulm.de/pm/projekte/TkGofer/tkg${PV}.tar.gz"
10
11 LICENSE="as-is" # see ${S}/Sources/goferite.h for exact wording
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND=">=dev-lang/tcl-7.6
17         >=dev-lang/tk-4.2
18         sys-libs/readline"
19 RDEPEND=${DEPEND}
20
21 S=${WORKDIR}/${PN}${PV}
22
23 src_unpack() {
24         unpack ${A}
25         cd "${S}"
26         epatch "${FILESDIR}/2.1-include-string.patch" \
27         "${FILESDIR}/2.1-gentoo-config.patch"
28 }
29
30 src_compile() {
31         lib="/usr/$(get_libdir)/${PN}"
32         rm Sources/prelude.h Sources/Makefile # ensure regeneration
33         ./tkgofer.install || die "tkgofer.install failed"
34         sed -i  -e"s:${S}:/usr:" \
35                 -e"s:\\(PreludeDir=\"\\).*\":\\1${lib}/Preludes\":" \
36                 -e"s:\\(BinDir=\"\\).*\":\\1${lib}/Bin\":" \
37                 -e"s:\\(TclDir=\"\\).*\":\\1${lib}/Tcl\":" \
38                 -e"s:\\(HelpDir=\"\\).*\":\\1/usr/share/doc/${PF}\":" \
39                 Bin/tkgofer || die "sed for tkgofer failed"
40 }
41
42 src_install() {
43         insinto ${lib}/Preludes || die
44         doins Preludes/* || die
45         insinto ${lib}/Tcl || die
46         doins Tcl/* || die
47         exeinto ${lib}/Bin || die
48         doexe Bin/{site.specific,tkgofer.exe} || die
49         dobin Bin/tkgofer || die
50         dodoc readme Doc/* || die
51 }