]> Pileus Git - ~andy/sunrise/blob - dev-lang/syx/syx-0.1.7.ebuild
x11-plugins/cairo-dock-plugins: Properly fix qt deps
[~andy/sunrise] / dev-lang / syx / syx-0.1.7.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="4"
6
7 DESCRIPTION="Open source implementation of the Smalltalk-80 programming language"
8 HOMEPAGE="http://syx.googlecode.com/"
9 SRC_URI="http://syx.googlecode.com/files/${P}.tar.gz"
10
11 LICENSE="MIT"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="gmp readline gtk X debug profile"
15
16 RDEPEND="gmp? ( dev-libs/gmp )
17         readline? ( sys-libs/readline )
18         gtk? ( x11-libs/gtk+:2 )
19         X? ( x11-libs/libX11 )"
20 DEPEND="${RDEPEND}"
21
22 src_configure() {
23         local myconf=
24         use debug && myconf='--enable-debug=info'
25
26         econf \
27                 $(use_enable gtk) \
28                 $(use_enable readline) \
29                 $(use_enable X x11) \
30                 $(use_enable profile) \
31                 $(use_with gmp) \
32                 ${myconf}
33 }