]> Pileus Git - ~andy/sunrise/blob - dev-lang/syx/syx-0.1.6.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update header
[~andy/sunrise] / dev-lang / syx / syx-0.1.6.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="Open source implementation of the Smalltalk-80 programming language."
6 HOMEPAGE="http://syx.googlecode.com"
7 SRC_URI="http://syx.googlecode.com/files/${P}.tar.gz"
8 LICENSE="MIT"
9 SLOT="0"
10 KEYWORDS="~amd64 ~x86"
11 IUSE="gmp readline gtk X debug profile"
12
13 RDEPEND="gmp? ( dev-libs/gmp )
14         readline? ( sys-libs/readline )
15         gtk? ( >=x11-libs/gtk+-2.12 )
16         X? ( x11-libs/libX11 )"
17
18 src_compile() {
19         local myconf="$(use_enable gtk)
20                         $(use_enable readline)
21                         $(use_enable X x11)
22                         $(use_enable profile)
23                         $(use_with gmp)"
24
25         use debug && myconf="${myconf} --enable-debug=info"
26
27         econf ${myconf} || die "Configure failed"
28
29         emake || die "Compile failed"
30 }
31
32 src_install() {
33         emake DESTDIR="${D}" install || die "Install failed"
34         dodoc README ChangeLog TODO
35 }