]> Pileus Git - ~andy/sunrise/blob - dev-lang/faust/faust-0.9.9.4.ebuild
app-dicts/words-bin: Adding ~amd64 keyword
[~andy/sunrise] / dev-lang / faust / faust-0.9.9.4.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils
8
9 DESCRIPTION="Functional programming language for realtime audio plugins and applications development"
10 HOMEPAGE="http://faust.grame.fr/"
11 SRC_URI="mirror://sourceforge/faudiostream/${P}b.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE="doc examples"
17
18 src_prepare() {
19         epatch "${FILESDIR}/${P}_Makefile.patch"
20 }
21
22 src_install() {
23         emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
24         dodoc README || die "Installing README failed"
25
26         if use doc; then
27                 dodoc documentation/faust{-quick-reference,-soft-computing,_tutorial}.pdf \
28                         || die "Installing docs failed"
29         fi
30
31         if use examples; then
32                 docinto examples
33                 dodoc examples/* || die "Installing examples failed"
34         fi
35 }
36
37 pkg_postinst() {
38         elog "Please note that faust is only concerned with creating C++ source "
39         elog "code. To actually compile this source code, you must have available "
40         elog "libraries for one or more of ALSA, jack, OSS, ladspa or PD"
41 }