]> Pileus Git - ~andy/sunrise/blob - dev-lang/cilk/cilk-5.4.6.ebuild
Whitespace
[~andy/sunrise] / dev-lang / cilk / cilk-5.4.6.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit flag-o-matic
6
7 DESCRIPTION="Language for multithreaded parallel programming based on ANSI C."
8 HOMEPAGE="http://supertech.csail.mit.edu/${PN}/"
9 SRC_URI="http://supertech.csail.mit.edu/${PN}/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="doc examples"
15
16 src_compile() {
17         # cilk compiler doesn't like this flags...
18         filter-flags "-pipe"
19         filter-flags "-ggdb"
20
21         econf
22         emake || die "emake failed"
23 }
24
25 src_install() {
26         emake DESTDIR="${D}" install || die "emake install failed."
27         dodoc NEWS README THANKS
28
29         use doc && dodoc doc/manual.pdf
30
31         if use examples; then
32                 docinto examples
33                 dodoc examples/*.{cilk,c,h}
34         fi
35 }