]> Pileus Git - ~andy/sunrise/blob - dev-lang/brainwash/brainwash-0.3.ebuild
dev-lang/brainwash: New ebuild for bug 143223. Thanks genstef.
[~andy/sunrise] / dev-lang / brainwash / brainwash-0.3.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="An optimizing interpreter for the Brainfuck programming language."
6 HOMEPAGE="http://brainwash.sourceforge.net/"
7 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
8
9 LICENSE="MIT"
10 SLOT="0"
11 KEYWORDS="~x86"
12 IUSE="char"
13
14 S="${WORKDIR}/${P}/src"
15
16 src_compile() {
17         if use char ; then
18                 emake char || die "emake failed"
19         else
20                 emake || die "emake failed"
21         fi
22 }
23
24 src_install() {
25         dobin brainwash
26         cd ..
27         dodoc README ChangeLog
28 }