]> Pileus Git - ~andy/sunrise/blob - dev-lang/brainwash/brainwash-0.3.ebuild
media-gfx/ktikz: Properly fix qt deps
[~andy/sunrise] / dev-lang / brainwash / brainwash-0.3.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="An optimizing interpreter for the Brainfuck programming language."
6 HOMEPAGE="http://brainwash.sourceforge.net/"
7 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
8
9 LICENSE="MIT"
10 SLOT="0"
11 KEYWORDS="~amd64 ~x86"
12 IUSE="char"
13
14 S="${WORKDIR}/${P}/src"
15
16 src_compile() {
17         sed -i -e "s:CFLAGS =:CFLAGS = ${CFLAGS}:" Makefile || die "sed failed"
18
19         if use char ; then
20                 emake char || die "emake failed"
21         else
22                 emake || die "emake failed"
23         fi
24 }
25
26 src_install() {
27         dobin brainwash
28         cd ..
29         dodoc README ChangeLog
30 }