]> Pileus Git - ~andy/sunrise/blob - dev-java/tigase-xmltools/tigase-xmltools-9999_pre2.ebuild
app-editors/yzis: Fix qt deps, EAPI bump
[~andy/sunrise] / dev-java / tigase-xmltools / tigase-xmltools-9999_pre2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 JAVA_PKG_IUSE="doc source"
6
7 ESVN_REPO_URI="https://svn.tigase.org/reps/${PN}/trunk"
8
9 inherit subversion java-pkg-2
10
11 DESCRIPTION="XML tools designed for XMPP."
12 HOMEPAGE="http://www.tigase.org/en/project/xmltools"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS=""
17 IUSE=""
18
19 DEPEND=">=dev-java/ant-1.7
20         >=virtual/jdk-1.6.0"
21
22 RDEPEND=">=virtual/jre-1.6.0"
23
24 src_unpack() {
25         subversion_src_unpack
26         cd "${S}"
27         ant clean-all
28 }
29
30 src_compile() {
31         ant jar || die "Compile failed"
32         if use doc; then
33                 ant docs || die "Docs failed"
34         fi
35 }
36
37 src_install() {
38         java-pkg_dojar jars/*.jar
39
40         use doc && java-pkg_dojavadoc docs-tigase-xmltools/api
41         use source && java-pkg_dosrc src/main/java/
42 }