]> Pileus Git - ~andy/sunrise/blob - dev-java/tigase-utils/tigase-utils-9999_pre2.ebuild
app-dicts/words-bin: Adding ~amd64 keyword
[~andy/sunrise] / dev-java / tigase-utils / tigase-utils-9999_pre2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 JAVA_PKG_IUSE="doc source"
6
7 ESVN_REPO_URI="https://svn.tigase.org/reps/${PN}/trunk"
8
9 inherit subversion java-pkg-2 eutils
10
11 DESCRIPTION="XMPP stanza helper utilities."
12 HOMEPAGE="http://www.tigase.org/en/project/utils"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS=""
17 IUSE=""
18
19 DEPEND=">=dev-java/ant-1.7
20         >=dev-java/tigase-xmltools-3.0
21         >=virtual/jdk-1.6.0"
22
23 RDEPEND=">=dev-java/tigase-xmltools-3.0
24         >=virtual/jre-1.6.0"
25
26 src_unpack() {
27         subversion_src_unpack
28         cd "${S}"
29         ant clean-all
30
31         epatch "${FILESDIR}/xmltoolsjar.patch"
32
33         sed -i -e "s:libs=libs:xmltoolsjar=$(java-pkg_getjar tigase-xmltools tigase-xmltools.jar):" build.properties
34 }
35
36 src_compile() {
37         ant jar || die "Compile failed"
38         if use doc; then
39                 ant docs || die "Docs failed"
40         fi
41 }
42
43 src_install() {
44         java-pkg_dojar jars/*.jar
45
46         use doc && java-pkg_dojavadoc docs-tigase-utils/api
47         use source && java-pkg_dosrc src/main/java/
48 }