]> Pileus Git - ~andy/sunrise/blob - dev-java/selenium-remote-control-bin/selenium-remote-control-bin-1.0.1.ebuild
www-misc/abloadtool: Fix qt deps
[~andy/sunrise] / dev-java / selenium-remote-control-bin / selenium-remote-control-bin-1.0.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit java-pkg-2
6
7 MY_P="${P/-bin/}"
8 MY_PN="${PN/-bin/}"
9
10 DESCRIPTION="Web application testing toolkit utilizing remote-control of a web browser"
11 HOMEPAGE="http://seleniumhq.org/projects/remote-control/"
12 SRC_URI="http://release.seleniumhq.org/${MY_PN}/${PV}/${MY_P}-dist.zip"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 DEPEND="app-arch/unzip"
20 RDEPEND=">=virtual/jre-1.5
21         x11-libs/libX11"
22
23 S="${WORKDIR}/${MY_P}"
24
25 src_install() {
26         java-pkg_newjar selenium-server-${PV}/selenium-server.jar
27         java-pkg_dolauncher
28 }
29
30 pkg_postinst() {
31         einfo "You will need a browser that selenium remote control can"
32         einfo "start and run tests. The list of supported browsers can"
33         einfo "be found here:"
34         einfo "http://seleniumhq.org/about/platforms.html#browsers"
35         einfo ""
36         einfo "Note that you must start selenium remote control within"
37         einfo "an X session of the user you intend run selenium scripts on."
38         einfo ""
39         einfo "You can use /usr/bin/selenium-remote-control-bin to start the"
40         einfo "selenium remote control."
41 }