]> Pileus Git - ~andy/sunrise/blob - dev-db/wxSQLite3/wxSQLite3-2.1.1.ebuild
sci-geosciences/aweather: Bump to 0.8, update homepage, and test on amd64
[~andy/sunrise] / dev-db / wxSQLite3 / wxSQLite3-2.1.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 WX_GTK_VER="2.8"
8
9 inherit eutils wxwidgets
10
11 DESCRIPTION="a C++ wrapper around the public domain SQLite 3.x database"
12 HOMEPAGE="http://wxcode.sourceforge.net/components/wxsqlite3/"
13 SRC_URI="mirror://sourceforge/wxcode/wxsqlite3-${PV}.tar.gz"
14
15 LICENSE="wxWinLL-3"
16 SLOT="0"
17 KEYWORDS="~x86"
18 IUSE="unicode"
19
20 DEPEND="
21         x11-libs/wxGTK:2.8[X]
22         dev-db/sqlite:3"
23 RDEPEND="${DEPEND}"
24
25 S="${WORKDIR}/wxsqlite3-${PV}"
26
27 src_configure() {
28         econf \
29                 $(use_enable unicode) \
30                 --enable-shared \
31                 --with-wx-config="${WX_CONFIG}" \
32                 --with-wxshared \
33                 --with-sqlite3-prefix=/usr
34 }
35
36 src_install() {
37         default
38
39         dodoc Readme.txt
40         dohtml -r docs/html/*
41         docinto samples
42         dodoc -r samples/*
43 }