]> Pileus Git - ~andy/sunrise/blob - dev-db/wxSQLite3/wxSQLite3-1.6.0.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / dev-db / wxSQLite3 / wxSQLite3-1.6.0.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 WX_GTK_VER="2.6"
6 inherit eutils wxwidgets
7
8 DESCRIPTION="a C++ wrapper around the public domain SQLite 3.x database"
9 HOMEPAGE="http://wxcode.sourceforge.net/components/wxsqlite3/"
10 SRC_URI="mirror://sourceforge/wxcode/wxsqlite3-${PV}.tar.gz"
11
12 LICENSE="wxWinLL-3"
13 SLOT="0"
14 KEYWORDS="~x86"
15 IUSE="unicode"
16
17 DEPEND="=x11-libs/wxGTK-2.6*
18         =dev-db/sqlite-3*"
19 RDEPEND="${DEPEND}"
20
21 S="${WORKDIR}/wxsqlite3"
22
23 src_unpack() {
24         unpack ${A}
25         cd "${S}"
26         epatch "${FILESDIR}/${P}-makefile_in.patch"
27 }
28
29 src_compile() {
30         use unicode && need-wxwidgets unicode
31
32         econf \
33                 $(use_enable unicode) \
34                 --enable-shared \
35                 --with-wx-config="${WX_CONFIG}" \
36                 --with-gtk \
37                 --with-wxshared \
38                 --with-sqlite3-prefix=/usr
39
40         emake || die "emake failed"
41 }
42
43 src_install() {
44         emake DESTDIR="${D}" install || die "emake install failed"
45
46         dodoc Readme.txt
47         dohtml -r docs/html/*
48         docinto samples
49         dodoc -r samples/*
50 }