]> Pileus Git - ~andy/sunrise/blob - dev-db/sqlitewrapped/sqlitewrapped-1.3.ebuild
sci-libs/grits: Version bump for grits-0.8.1
[~andy/sunrise] / dev-db / sqlitewrapped / sqlitewrapped-1.3.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit toolchain-funcs
6
7 KEYWORDS="~x86"
8
9 DESCRIPTION="Another C++ wrapper for the SQLite C API"
10 HOMEPAGE="http://www.alhem.net/project/sqlite/index.html"
11 SRC_URI="http://www.alhem.net/project/sqlite/${P}.tar.gz"
12 LICENSE="GPL-2"
13 SLOT="0"
14 IUSE=""
15
16 DEPEND=">=dev-db/sqlite-3"
17 RDEPEND="${DEPEND}"
18
19 src_unpack() {
20         unpack ${A}
21         cd "${S}"
22
23         sed -i \
24                 -e 's/\(CPPFLAGS\) =/\1+=/' \
25                 -e 's/-Wall -g -O2/-fPIC/' \
26                 -e 's#/usr/devel#/usr#' \
27                 Makefile || die "sed failed"
28 }
29
30 src_compile() {
31         emake CXX="$(tc-getCXX)" || die "emake failed"
32 }
33
34 src_install() {
35         dolib libsqlitewrapped.a
36         insinto /usr/include
37         doins libsqlitewrapped.h
38 }