]> Pileus Git - ~andy/sunrise/blob - dev-db/soci/soci-3.1.0.ebuild
games-board/qbriscola: Fix qt deps, EAPI bump, add ~amd64 keyword
[~andy/sunrise] / dev-db / soci / soci-3.1.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit cmake-utils
8
9 KEYWORDS="~amd64 ~x86"
10
11 DESCRIPTION="A db access library for C++ that makes the illusion of embedding SQL queries in the regular C++ code"
12 HOMEPAGE="http://soci.sourceforge.net/"
13 SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
14 LICENSE="Boost-1.0"
15 SLOT="0"
16 IUSE="boost doc +empty mysql odbc oracle postgres sqlite"
17
18 DEPEND="boost? ( dev-libs/boost )
19         mysql? ( virtual/mysql )
20         odbc? ( dev-db/unixODBC )
21         oracle? ( dev-db/oracle-instantclient-basic )
22         postgres? ( dev-db/postgresql-base )
23         sqlite? ( dev-db/sqlite:3 )
24 "
25 RDEPEND=${DEPEND}
26
27 src_configure() {
28         local mycmakeargs="$(cmake-utils_use_with boost )
29                 $(cmake-utils_use empty SOCI_EMPTY)
30                 $(cmake-utils_use_with mysql MYSQL)
31                 $(cmake-utils_use_with odbc ODBC)
32                 $(cmake-utils_use_with oracle ORACLE)
33                 $(cmake-utils_use_with postgres POSTGRESQL)
34                 $(cmake-utils_use_with sqlite SQLITE3)"
35         cmake-utils_src_configure
36 }
37
38 src_install() {
39         cmake-utils_src_install
40         dodoc AUTHORS CHANGES
41         if use doc; then
42                 dohtml -r doc/*
43         fi
44 }