]> Pileus Git - ~andy/sunrise/blob - dev-db/pysql/pysql-0.13.ebuild
sci-libs/grits: Version bump for grits-0.8.1
[~andy/sunrise] / dev-db / pysql / pysql-0.13.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 PYTHON_DEPEND="2"
8
9 inherit python distutils
10
11 DESCRIPTION="An Oracle enhanced client"
12 HOMEPAGE="http://pysql.sourceforge.net/"
13 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="graphviz"
19
20 DEPEND=">=dev-python/cx-oracle-5.0.2
21         graphviz? (
22                 media-gfx/graphviz
23                 media-gfx/pydot
24         )"
25 RDEPEND="${DEPEND}"
26
27 src_install() {
28         distutils_src_install
29
30         if [[ -d "${D}"/usr/share/pysql ]]; then
31                 rm -r "${D}"/usr/share/pysql || die
32         fi
33 }