]> Pileus Git - ~andy/sunrise/blob - dev-db/dbf/dbf-0.9.0.ebuild
dev-libs/qextserialport: Fix qt deps, EAPI bump
[~andy/sunrise] / dev-db / dbf / dbf-0.9.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 MY_PN="${PN}-core"
6 MY_P="${MY_PN}-${PV}"
7 DESCRIPTION="Command line tool to convert dBASE (III, IV, 5.0) files to CSV or SQL"
8 HOMEPAGE="http://developer.berlios.de/projects/dbf/"
9 SRC_URI="mirror://berlios/${PN}/${MY_P}.src.zip"
10
11 LICENSE="LGPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="doc"
15
16 RDEPEND="dev-libs/libdbf"
17 DEPEND="${RDEPEND}
18         app-arch/unzip
19         dev-perl/XML-Parser
20         doc? ( app-text/docbook-sgml-utils )
21         virtual/pkgconfig"
22
23 S=${WORKDIR}/${MY_PN}
24
25 src_compile() {
26         sed -i 's/docbook-to-man/$(DOC_TO_MAN)/' man/Makefile*
27         chmod u+x configure
28         if use doc; then
29                 export DOC_TO_MAN=docbook2man
30         fi
31         econf
32         emake || die "emake failed"
33         if use doc; then
34                 mv man/DBF.SECTION man/dbf.1 || die "Error moving man page"
35         fi
36 }
37
38 src_install() {
39         chmod u+x install-sh
40         emake DESTDIR="${D}" install || die "make install failed"
41 }