]> Pileus Git - ~andy/sunrise/blob - dev-db/daboide/daboide-0.5.6.ebuild
67f6a2890219e10b7a95f4050da57ddaf7d7043b
[~andy/sunrise] / dev-db / daboide / daboide-0.5.6.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit distutils
6
7 DESCRIPTION="An Integrated Development Environment for dabo"
8 HOMEPAGE="http://dabodev.com/"
9 SRC_URI="ftp://dabodev.com/dabo/${P}-mac-nix.tar.gz"
10 LICENSE="MIT"
11 SLOT="0"
12 KEYWORDS="~x86"
13 IUSE=""
14 S=${WORKDIR}/${PN}
15
16 DEPEND="app-arch/gzip
17         app-arch/tar"
18
19 RDEPEND=">=dev-python/wxpython-2.5.2.8
20         dev-db/dabo
21         dev-python/imaging
22         dev-python/reportlab
23         ${DEPEND}"
24
25 distutils_src_compile() {
26         # Prevent inherited method from trying to run setup.py
27         false
28 }
29
30 src_install() {
31         # Install daboide into site-packages
32         distutils_python_version
33         INS=/usr/lib/python${PYVER}/site-packages/${P}
34
35         dodoc ChangeLog
36
37         # for each source directory
38         for DDIR in $(find . -type d)
39         do
40                 # if there are any files - install them
41                 if [ $(ls -l ${DDIR} | grep ^[-l] | wc -l) != "0" ]
42                 then
43                         insinto ${INS}/${DDIR}
44                         doins ${DDIR}/*
45                 fi
46
47                 # if we have any python files
48                 if [ $(ls -l ${DDIR}/*.py 2>/dev/null | wc -l) != "0" ]
49                 then
50                         # pick out those files which should be executable
51                         EFIL=$(grep '^#!' ${DDIR}/*.py | cut -d : -f 1)
52
53                         # and if there are any - install them
54                         if [ -n "${EFIL}" ]
55                         then
56                                 exeinto ${INS}/${DDIR}
57                                 doexe ${EFIL}
58                         fi
59                 fi
60         done
61
62         # Create executable
63         echo '#!/bin/sh' > daboide
64         echo "exec /usr/lib/python${PYVER}/site-packages/${P}/IDE.py" >> daboide
65         dobin daboide
66 }
67
68 #pkg_postinst() {
69         # There is currently a problem trying to optimise some of the files
70         # under AppWizard
71         #python_mod_optimize ${D}
72 #}