]> Pileus Git - ~andy/sunrise/blob - dev-db/dabo/dabo-0.8.4.ebuild
dev-db/dabo: Version bump.
[~andy/sunrise] / dev-db / dabo / dabo-0.8.4.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit distutils multilib
6
7 DESCRIPTION="A 3-tier, cross-platform application development framework written in Python/wxPython."
8 HOMEPAGE="http://dabodev.com/"
9 SRC_URI="ftp://dabodev.com/dabo/${P}.tar.gz"
10
11 LICENSE="MIT"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE="ide"
15
16 DEPEND=">=dev-python/setuptools-0.6_alpha9
17         ide? ( !dev-db/daboide )"
18
19 RDEPEND=">=dev-python/wxpython-2.6.1.1
20         >=dev-db/sqlite-3.0
21         >=dev-python/pysqlite-2.0
22         ide? ( dev-python/imaging dev-python/reportlab )
23         ${DEPEND}"
24
25 S="${WORKDIR}/${PN}"
26
27 src_install() {
28         distutils_python_version
29         ${python} setup.py install --root="${D}" --no-compile \
30                 --single-version-externally-managed "$@" \
31                 --install-data="/usr/$(get_libdir)/python${PYVER}/site-packages/" \
32                 || die "setup.py install failed"
33
34         dodoc ANNOUNCE AUTHORS ChangeLog README TODO
35
36         if use ide
37         then
38                 cd "${S}/ide"
39                 INS="/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}/ide"
40
41                 insinto ${INS}
42                 doins -r *
43
44                 # pick out those files which should be executable
45                 for EFIL in $(grep -RI '^#!' * | cut -d : -f 1 | grep -iv '\.txt$')
46                 do
47                         # and if there are any - install them
48                         exeinto "${INS}/$(dirname ${EFIL})"
49                         doexe "${EFIL}"
50                 done
51         fi
52 }