]> Pileus Git - ~andy/sunrise/blob - dev-db/dabo/dabo-0.8.2.ebuild
dev-db/dabo: Quote $D.
[~andy/sunrise] / dev-db / dabo / dabo-0.8.2.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit distutils multilib
6
7 DESCRIPTION="A 3-tier, cross-platform application development framework written in Python atop the wxPython GUI toolkit"
8 HOMEPAGE="http://dabodev.com/"
9 SRC_URI="ftp://dabodev.com/dabo/${P}-mac-nix.tar.gz"
10
11 LICENSE="MIT"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE=""
15
16 DEPEND=">=dev-python/setuptools-0.6_alpha9"
17
18 RDEPEND=">=dev-python/wxpython-2.6.1.1
19         >=dev-db/sqlite-3.0
20         >=dev-python/pysqlite-2.0
21         ${DEPEND}"
22
23 S="${WORKDIR}/${PN}"
24
25 src_install() {
26         distutils_python_version
27         ${python} setup.py install --root="${D}" --no-compile \
28                 --single-version-externally-managed "$@" \
29                 --install-data="/usr/$(get_libdir)/python${PYVER}/site-packages/" \
30                 || die "setup.py install failed"
31
32         dodoc ANNOUNCE AUTHORS ChangeLog README TODO
33 }