]> Pileus Git - ~andy/sunrise/blob - dev-db/dabo/dabo-0.6.6.ebuild
app-office/tinyerp-server: fix fowner
[~andy/sunrise] / dev-db / dabo / dabo-0.6.6.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit distutils
6
7 DESCRIPTION="A 3-tier, cross-platform application development framework written in Python atop the wxPython GUI toolkit"
8 HOMEPAGE="http://dabodev.com/"
9 SRC_URI="ftp://dabodev.com/dabo/${P}-mac-nix.tar.gz"
10 LICENSE="MIT"
11 SLOT="0"
12 KEYWORDS="~x86"
13 IUSE=""
14 S=${WORKDIR}/${PN}
15
16 DEPEND=">=dev-python/setuptools-0.6_alpha9"
17
18 RDEPEND=">=dev-python/wxpython-2.5.2.8
19         !>=dev-python/wxpython-2.7
20         ${DEPEND}"
21
22 src_install() {
23         ${python} setup.py install --root=${D} --no-compile \
24                 --single-version-externally-managed "$@" || die "setup.py install failed"
25
26         dodoc ANNOUNCE AUTHORS ChangeLog README TODO
27 }