]> Pileus Git - ~andy/sunrise/blob - dev-cpp/stringencoders/stringencoders-3.10.3.ebuild
x11-libs/libqglviewer/: Fix qt deps
[~andy/sunrise] / dev-cpp / stringencoders / stringencoders-3.10.3.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit autotools eutils
8
9 MY_P="${PN}-v${PV}"
10 DESCRIPTION="A collection of high performance c-string transformations"
11 HOMEPAGE="http://code.google.com/p/stringencoders/"
12 SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE=""
18
19 S=${WORKDIR}/${MY_P}
20
21 src_prepare() {
22         epatch "${FILESDIR}"/${P}-werror.patch
23
24         eautoreconf
25 }
26
27 # default `make check` doesn't work
28 src_test() {
29         emake test
30 }